Jimmy小站

小明也有大梦想 — 蒋明/铭
当前位置:网站首页 / Spring MVC / 正文

ssh开发框架tomcat启动时,发生 model $$_javassist_13 cannot be cast to javassist.util.proxy.Proxy 错误

2016-05-15 / Spring MVC / 2517 次围观 / 0 次吐槽

原因是javassist包的冲突造成,如下,在hibernate中有3.20.0-GA版本,在struts2的ognl中也有一个javassist包,且版本不一致。

我们需要exclude其中一个。

QQ截图20160515173140.png

我选择在pom.xml中exclude掉struts2中的javassist 如下

<dependency>
        <groupId>org.apache.struts</groupId>
        <artifactId>struts2-spring-plugin</artifactId>
        <version>2.3.28.1</version>
        <exclusions>
            <exclusion>
                <groupId>javassist</groupId>
                <artifactId>javassist</artifactId>
            </exclusion>
        </exclusions>
    </dependency>

重新编译启动,正常

推荐您阅读更多有关于“SSH开发,”的文章

[一个Java程序猿的转型之路,读研深造,专注机器学习推荐算法]
本站所有文章如无特别注明均为原创。作者:吉米酱 ,复制或转载请以超链接形式注明转自 Jimmy小站
原文地址《ssh开发框架tomcat启动时,发生 model $$_javassist_13 cannot be cast to javassist.util.proxy.Proxy 错误
额 本文暂时没人评论 来添加一个吧

发表评论

必填

选填

选填

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。

Copyright © Jimmy小站 Allrights Reserved.备案号:桂ICP备 15005996